Degraded performance impacting some customers

Incident Report for Gladstone Software

Postmortem

During the incident, the service experienced degraded performance due to contention within the SQL architecture.

As a result, affected areas of the platform experienced slower response times and, in some cases, delays completing requests. The issue was identified as database contention rather than a failure of the application itself.

To resolve the issue, we investigated the database operations, and took corrective action to reduce the contention. Service performance returned to normal once the affected workload was cleared and normal processing resumed.

To help prevent a recurrence, with a focus on reducing long-running operations, and strengthening monitoring so that similar contention is detected earlier.

Posted Jul 17, 2026 - 16:06 UTC

Resolved

Degraded performance in Gladstone360 and Plus2
Posted Jul 13, 2026 - 08:00 UTC